Elektronik2000.de Forum
» E2000 - PLUS - Software
» E2000 - PLUS - Logik
Drehstromzähler Verbrauchsanzeige und Auswertung
Seiten (3): « 1 2 [3]  
Autor Beitrag
 
Netti14 (Entwickler)
Aah sorry, ich bin davon ausgegangen, das du ein Impuls/Frequenz device dran hast.
Da mach ich mir zu deiner Schaltung mal Gedanken...
_________________________
Desto mehr ich weiß, weiß ich, das ich nichts weiß!
Netti14 ist offline  
 
Mikele
Hallo Fillip13,

wenn du die Anzeige in kWh haben willst, müsstest du durch 2000 teilen. Du hast aber mit 5 mal genommen :) = Normaler Smile

Das Loggen über einen AND-Baustein klappt so auch nicht. Ich hab das mit einem Relais-Baustein gemacht.

Gruß,
Mikele
_________________________
E2000+ auf Raspberry Pi B; 4 x Multi-IO UP-Module; 1x Input Modul 2fach; 1 x Dimmer-Modul; 1x LCD-Modul (ungetestet)
Mikele ist offline  
 
fillip13 (Betatester)
Hi Mikele,

hab die Schaltung gestern nochmal geändert, läuft jetzt glaube ich richtig. Im Designer werden mir jedenfalls sinvollere Daten angezeigt *gut* = Sehr gut!

Das mit dem Logger habe ich (dank deinem Tipp) nochmal geändert ;-) Hab im Anhang nochmal die neue Datei falls es jemand auch mal interessiert *verrückt* = Verrückt!
Anhänge
Verbrauch.e2kx (11,3 KB)
fillip13 ist offline  
 
Magican
Zitat von Magican:
Hier die Elektronik



Die zählt bis 500 und dann wir das Relais geschalten.

Hab das Ganze in ein Gehäuse von PhönixContact gebaut

https://www.distrelec.de/geh%C3%A4use-unterte[...]me-22-5-ut-gn/300341



Hallo zusammen,
wir haben einen neuen Stromzähler bekommen, ISKRA SBZ17, dieser hat eine integrierte Schnittstelle welche ich mit dem ELV LED ES-LED Sensor auslesen kann. Leider liefert dieser jetzt Signale mit fallender Flanke und ich kann die vorhandene Schaltung mit dem "BGTech Zwischenzähler und 500 Zählen und dann Relais schalten" nicht mehr nutzen da hier die 5V von der Schaltung kommen.
Könnte mir jemand weiterhelfen wie ich die Eingangsbeschaltung anpassen muss? Sprich welcher Transistor wie beschalten? Der ELV Sensor hat 3 Adern: +, - und Signal. Das Signal ist gegen
"-" gemessen wie im Bild.
Danke!
Anhänge
Oszi.png (34,6 KB)
Magican ist offline  
 
chemboy (Betatester)
Hallo,
wenn ich mich nicht irre müssten die zwei zusammen funktionieren.ist doch egal ob mit fallender oder steigender flanke, die anzahl der Impulse bleiben gleich.

Grüße jürgen
Zuletzt bearbeitet 04.05.2020 - 17:15:42 Uhr von chemboy
chemboy ist offline  
 
Magican
Der B+G Zähler wurde ausgebaut und jetzt soll das Ganze mit dem Hauptzähler und dem ELV Sensor laufen.

Beim B+G Zähler war eine einfache S0 Schnittstelle ohne integrierter Speisespannung
Beim ELV Sensor kommen pratkisch schon die 5V TTL als Signal raus da er eine Elektronik verbaut hat

Oder kann ich den Sensor auch an einem Impuls/Frequenz Modul anschließen? Da verstehe ich aber auch nicht ganz wie ich die zwei Adern anschließen soll: "Signal EVL 5V" auf "Input" und "ELV 0V" auf "-"?

Das mit dem Impuls/Frequenz Modul dürfte auch schwierig werden da der MOS 4584 bei Reichelt nicht mehr lieferbar ist.
Magican ist offline  
 
chemboy (Betatester)
Du schliesst den elv sensor einfach an deinen Frequenzteiler an. Die 5V nimmst du vom Frequenzteiler und den Impulsausgang mit dem Impulseingang verbinden.
Probiere das mal.
Wenn das funktioniert wuerde ich das Relais beim Frequenzteiler einsparen.
Du kannst aber auch das e2000 Impulsmodul anschliessen,so hab ich das.

Gruss Juergen
chemboy ist offline  
 
chemboy (Betatester)
Bezueglich mos 4584 siehe :
http://www.elektronik2000.de/forum/thread.php?id=2583
chemboy ist offline  
 
Magican
Hallo Chemboy,
ich habe mir jetzt das Impuls Modul zugelegt, wenn das bei dir so läuft sollte es bei mir ja auch :-)
Leider komm ich aber mit den Einstellungen der Entprellung nicht ganz klar. Ist der aktuelle Stromverbrauch hoch kommen auch mehr Impulse / Sekunde. Wie stell ich dann die Entprellung richtig ein?

Könntest du mir mal deine Verdrahtung und Einstellungen zeigen?
Danke
Anhänge
Übersicht.png (156,5 KB)
Magican ist offline  
 
chemboy (Betatester)
Hallo,
ich habe als Eingang "impulse pro Minute " gewählt mit 0ms entprellung. Bei 5V Impulsen brauchst Du die Zehnerdiode am Eingang nicht die kannste deaktivieren. Warum nimmst Du nicht die 5V vom Impulsboard? Siehe Schaltplan.
Hab gerade noch gesehen,du musst auf RV gehen, nicht auf 1(siehe Leiterplatte)

Grüße
Zuletzt bearbeitet 19.05.2020 - 22:56:24 Uhr von chemboy
chemboy ist offline  
Seiten (3): « 1 2 [3]  
 
Suche
» Erweiterte Suche
Optionen
Druckansicht Druckansicht
Thema weiterempfehlen Thema weiterempfehlen