Elektronik2000.de

Elektronik2000.de Forum (http://www.elektronik2000.de/forum/)
-- E2000 - PLUS - Software (http://www.elektronik2000.de/forum/forum.php?id=117)
  -- E2000 - PLUS - Software allgemein (http://www.elektronik2000.de/forum/forum.php?id=126)


Seiten (6): « 1 2 3 4 5 [6]
 
Magican
Zitat von Tropby:
Hallo Magican,
ich habe jetzt mal nachgesehen wie die CPU-Last berechnet wird.

Zitat:

Wie ist die Auslastung des Systems in der Übersicht mit z.b. 4.125 zu verstehen? Sind das Prozent?


Die 4.125 sind als 41,25 % Auslastung zu interpretieren. Ich weiß auch nicht wieso ich das durch 10 geteilt habe *verwirrt* = Verwirrter Smilie Denkt bitte dran, dass die Logik maximal einen CPU-Kern verwenden kann und der BUS auch nur einen Kern. Das heißt BUS+Logik können bei einem 4-Kern Raspberry Pi nur 50% Auslasung erzeugen.

Gruß
Tropby



Hallo Tropby,
danke für die Info, dann kommt mein Raspi anscheinend bald an die Grenzen, bin ja mal gespannt was V4 so bringt wenn die Software die Hardware unterstützt.

Mir ist gerade noch aufgefallen dass meine fünf Feuchtefühler DHT22 jeweils an einem Multi 8-fach UP seit dem Update auf V4.3_1557 einen Festwert von -3276,4 anzeigen, kann das mal jemand prüfen oder ist bei mir was faul? Vor dem Update haben die meines Wissens noch funktioniert
 
joba104 (Betatester)
Hab mal 1400 Logikbausteine geladen. Die Logikgeschwindikkeit ist 140 und die Prozessorauslastung bis 7,1 und die Temperatur 66. Der Prozess SNTP geht nach einigen Tagen auf Fehler und letzte Abfrage: Timeout. Nächste Abfrage steht dauernd bei 29 Min und 58Sek.

Der Übertragungsfehler war bei 3 und nachdem alle Module mit den neuen Updates versehen waren wieder bei 0,0.

Außer SNTP und die Logger- Bezeichnung funktioniert bei mir bis jetzt alles wieder problemlos.

Gruß Joba
 
Magican
Zitat von joba104:
Hab mal 1400 Logikbausteine geladen. Die Logikgeschwindikkeit ist 140 und die Prozessorauslastung bis 7,1 und die Temperatur 66. Der Prozess SNTP geht nach einigen Tagen auf Fehler und letzte Abfrage: Timeout. Nächste Abfrage steht dauernd bei 29 Min und 58Sek.

Der Übertragungsfehler war bei 3 und nachdem alle Module mit den neuen Updates versehen waren wieder bei 0,0.

Außer SNTP und die Logger- Bezeichnung funktioniert bei mir bis jetzt alles wieder problemlos.

Gruß Joba


Okay das ist ja Wahnsinn, Logik mit 1400 Bausteinen! Ich habe gerade mal 424 und 72 ° Prozessortemperatur und eben eine Auslastung von 41%. (Raspi 3B mit SanDisk Ultra 16GB microSDHC Class 10, U1, A1)
Haben den die Bausteine unterschiedliche Rechenkapazität oder was benötigt viel Prozessorleistung, z.B. viele Bus Module? Eine Tabelle mit Belastungswerten wäre da vielleicht mal eine gute Info. Ich nutze z.B. nur sehr wenig lokale IRCP weil ich irgendwie den Anschein hab das diese z.B. den Tastendruck bei einem Eingang verzögern - kann aber auch nur Einbildung sein.
 
joba104 (Betatester)
Hallo Magican,
ich habe viele Berechner und IRCP Lokal und öffentlich. Erstaunlich, dass trotzdem die Logik-Geschwindigkeit bei 140 liegt und noch Reserven vorhanden sind.

Gruß
Joba
 
Manni-Pi (Entwickler)

Manni
Hallo,
nur mal als Info. Seit dem letzten Update wurde die Geschwindigkeit durch Optimierung extrem gesteigert. In meinem Hauptsystem werkeln 3 Raspis.
Als Master ein ein Raspi 3 B+ mit 1853 Bausteinen der jetzt noch 155Hz und Logik-Simulation-Timer 6 hat. (Mit der alten Firmware 100Hz und Logik-Simulation-Timer 0)
Als Slave1 ein ein Raspi 3 B mit 535 Bausteinen der jetzt noch 140Hz und Logik-Simulation-Timer 7 hat.
Als Slave1 ein ein Raspi 2 B mit 452 Bausteinen der jetzt noch 155Hz und Logik-Simulation-Timer 4 hat.
Das Ganze bedient 23 Module.
Alles kommuniziert im Haus über IRCP und MQTT.
Zusätzlich sind 15 WEMOS-D1 Module und Sonoff Schalter mit integriert.
In Meinem Testsystem läuft gerade ein Raspi4 aber noch mit einer sehr frühen Testversion die noch nicht alles unterstützt. Aber immerhin, es läuft *gut* = Sehr gut!
Die Leistung von E-2000 Plus ist mittlerweile echt erstaunlich.
Gruß
Manfred 8) = Cooler Smilie
 
Magican
Hallo Manfred,

wird der 3B+ schon unterstützt oder meintest du den 3B?
Ich bin noch auf diesen Stand
http://www.elektronik2000.de/News/114/18.03.18/Raspberry%20Pi%203B+

Hm vielleicht liegt meine hohe Prozessorauslastung an den jeweils 20 Busmodulen oder 50m Leitungsweg die ich an jedem 3B angeschlossen hab.
Dann werde ich mir mal einen 3B+ anschaffen wenn du sagst das der funktioniert, bis der 4er unterstützt wird dauert es bestimmt noch oder kannst du das ungefähr einschätzen wenn du den schon im Test hast?Ist das eine spezielle Firmware oder auch 4.3 1557
Danke für deine Info
Gruß Sebastian
 
Manni-Pi (Entwickler)

Manni
Hallo Sebastian,
ich habe einige Firmwareversionen getestet und kann nicht genau sagen welche ich jetzt auf der SD Karte des Raspi 3B+ installiert habe. Ich denke aber die Firmware vom 05.09.2018 die bei der Version 1557 dabei ist sollte auf einem 3B+ laufen. Der Raspi 3B+ hat aber gegenüber dem Raspi 3B meiner Meinung nach keinen riesen Geschwindigkeitsvorteil gebracht. Ich glaube fast, dass dir der Umstieg nicht so viel bringt. Da, wie Trophy schon angesprochen hatte, ja nur ein Kern für den Bus und ein Kern für die Software genutzt wird ist der Unterschied eher nicht so groß.*verrückt* = Verrückt!
Du musst auf jeden Fall die SD-Karte neu machen und dann deine Datensicherung einspielen.
Wenn du es testen willst und es Probleme gibt dann melde dich einfach nochmal.

Gruß und bleib gesund
Manfred 8) = Cooler Smilie
 
rwn2014
Raspberry Pi 3 Modell B V1.2
Hallo Allerseits,
ich versuche gerade verzweifelt auf einen Raspberry Pi 3 Modell B V1.2 die Firmware 4.3 zu installieren.
Bis 4.0 klappt alles gut. Dann bei update auf 4.1 die Meldung "Update abgebrochen".
Was kann ich tun?

Danke und Gruß
Gerd
 
Manni-Pi (Entwickler)

Manni
Hallo Gerd,
hast du noch ein altes ADD-Board mit Watchdog und den Jumper nicht gesetzt??? Der Watchdog muss aus sein sonst wird der Raspi neu gestartet bevor der Updatevorgang abgeschlossen ist und die Karte wird zerschossen. Wenn du den Raspi direkt mit Spannung aus einem Netzteil versorgst ohne an das ADD oder Starterboard anzuschließen sollte es funktionieren. Das Update braucht echt lange da die Partition der SD-Karte auf volle Größe aufgebohrt wird.

Gruß
Manfred 8) = Cooler Smilie
Seiten (6): « 1 2 3 4 5 [6]
 

02.06.2020 - 15:44:55